PDA

View Full Version : dependency error



tarcisiocouto
28-03-2012, 09:10 PM
hello guys, everything alright?

i'm working in a project where i installed the following plugins: spring-security-core, mails, jquery, jqueryUi, famfamfam e spring-security-ui. My intention was do the authentication and authorization of the system. After the installation was everything right, the was project run in my computer and continue running.

I did the "commit" with all alteration of the project and anyone of my group can run it.
Ever that the grails try solve the dependency of the project, download the plugins, the following erros happen


| Loading Grails 2.0.1
| Configuring classpath
| Downloading: mail-1.0.pom.sha1
| Downloading: mail-1.0.pom.sha1
| Downloading: spring-security-core-1.2.7.2.pom.sha1
| Downloading: spring-security-core-1.2.7.2.pom.sha1
| Downloading: spring-security-ui-0.2.pom.sha1
| Downloading: spring-security-ui-0.2.pom.sha1
| Downloading: mail-1.0.pom.sha1
| Downloading: mail-1.0.pom.sha1
| Downloading: spring-security-core-1.2.7.2.pom.sha1
| Downloading: spring-security-core-1.2.7.2.pom.sha1
| Downloading: spring-security-ui-0.2.pom.sha1
| Downloading: spring-security-ui-0.2.pom.sha1
| Error Failed to resolve dependencies (Set log level to 'warn' in BuildConfig.groovy for more information):

- org.grails.plugins:mail:1.0
- org.grails.pluginspring-security-core:1.2.7.2
- org.grails.pluginspring-security-ui:0.2

We are using the sts 2.9.0 and grails 2.0.1

I already looked on the internet, but don't getting a good solution to solve this problem. What can i do to solve this problem ? I have to send this project in the end of this week.

Thank you to help us.

Tarcísio Couto